Starszy Android może powodować wiele problemów, a do tego za chwilę może dojść kolejny. Chodzi o niektóre strony internetowe, które w 2021 roku, mogą już nie wczytywać się poprawnie lub też w ogóle. Wszystko przez certyfikat, który nie będzie dalej wspierany oraz fakt, że starsze sprzęty z Androidem mogą mieć problem z obsługą stron internetowych, które z niego korzystają. I chodzi tutaj o około 30 procent wszystkich stron w sieci.

Starszy Android i obsługa stron internetowych

starszy Android strony internetowe
Fot. PixaBay

Dobrze wiemy, że fragmentacja Androida wygląda dość kiepsko. Z najnowszej wersji systemu korzysta niewielka część użytkowników smartfonów, choć zdaje się, że to powoli się zmienia. Jednak starsze wersje systemu Google dalej są w użyciu. To w przyszłym roku może spowodować trochę problemów. Chodzi o wersje Android 7.1.1 i niższe, które od września 2021 mogą mieć problem z obsługą stron internetowych. O co chodzi?

Let’s Encrypt to instytucja zajmująca się certyfikacją witryn internetowych, a z ich rozwiązań korzysta blisko 30 procent wszystkich domen internetowych. Instytucja przed laty wystąpiła o to, by włączyć do przeglądarek internetowych oraz systemów operacyjnych certyfikat główny ISRG Root X1, który został podpisany krzyżowo z IdenTrust DST Root X3. Teraz firma poinformowała, że nie zdecydowała się na to, by dalej podpisywać krzyżowo certyfikat. Po 1 września 2021 roku, przeglądarki oraz systemy operacyjne bez certyfikatu Let’s Encrypt, mogą nie działać już ze stronami internetowymi, które z niego korzystają. W oficjalnym komunikacie na stronie Let’s Encrypt można przeczytać następującą informację.

Niektóre programy, które nie były aktualizowane od 2016 r. (mniej więcej wtedy, gdy nasz root został zaakceptowany dla wielu programów głównych) nadal nie ufają naszemu certyfikatowi głównemu, ISRG Root X1. Przede wszystkim dotyczy to wersji Androida wcześniejszych niż 7.1.1. Oznacza to, że starsze wersje Androida nie będą już ufać certyfikatom wystawionym przez Let’s Encrypt.

Zobacz też: Zdjęcia Google z płatnym dostępem – firma testuje kontrowersyjne rozwiązanie.

Co zrobić, jeżeli ma się starszego Androida?

Choć zakończenie podpisywania krzyżowego ma nastąpić we wrześniu 2021 roku. Jednak już od 11 stycznia 2021 roku, Let’s Encrypt ma przestać to robić. Jednak strony mają dalej działać normalnie właśnie do września. Co więc zrobić, jeżeli korzysta się ze starszej wersji systemu Google? Można skorzystać z przeglądarki Firefox, która korzysta z własnych certyfikatów. Nie oznacza to, że wszystkie aplikacje będą działały poprawnie. Niektóre mogą sprawiać kłopoty. Czy problem dotyczy dużej liczby użytkowników? Obecnie około 33 procent wszystkich sprzętów z Androidem korzysta z wersji 7.1.1 lub niższej. I ci użytkownicy mogą doświadczać problemów z certyfikatami na stronach internetowych.

Źródło: Let’s Enrcypt / Android Police

Google News
Obserwuj ANDROID.COM.PL w Google News i bądź zawsze na bieżąco!
Obserwuj

Bartosz Szczygielski

Nowymi technologiami zajmuje się od kilku lat. Kiedy o nich nie pisze, to pewnie pisze kolejną książkę. Jeżeli nie pisze kolejnej książki, to pewnie ogląda seriale, a jeżeli nie ogląda seriali, to najprawdopodobniej śpi.